Issue joining new meetings
Incident Report for VOXO
Resolved
This incident has been resolved.
Posted Apr 04, 2023 - 15:37 CDT
Identified
We have identified the issue where some users are unable to join new meetings.
Posted Apr 04, 2023 - 14:03 CDT
This incident affected: Meetings.